Page 1 sur 1

ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 29 Fév 2020 17:40
par Mr Coyote
Bonjour,

après la mise à jour des OS des VM, donc la mise à jour de Debian 8 vers Debian 9 et auparavant de DSM 5.2 vers DSM 6.2, il me restait à faire la mise à jour de l'OS de mon HP ProLiant Gen 10 d'ESXI 6.5 vers ESXI 6.7. J'ai trouvé l'image zip à utiliser et les lignes de commande.

Par contre, je coince sur un problème d'espace disque. Je veux transférer le zip de 330 MB dans /tmp mais il n'en charge que 260 MB environ. Si je charge un autre fichier, il ne le charge pas (taille du fichier =0). Ce qui voudrait donc dire que le HDD est plein. Or, tout cela (ESXI + Debian 9 & DSM 6.2) se trouve sur un disque de 290 GB dont 143 GB sont libres.

Dans le host, en m'y connectant sous 192.168.0.25, dans la partie Storage, j'ai bien un datastore StockVM de 290.5 GB, free = 143 GB.

Que faire?

Merci,
Coyote

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 29 Fév 2020 18:58
par mackguil
La taille du disque de la vm est il suffisante ?

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 29 Fév 2020 19:08
par Mr Coyote
Le DSM 6.2 a un espace de 16 GB en independent persistent
Debian 9 a 256 GB en thin provisioned et en prend 4
Pour le host je ne vois pas d'infos à partir que le disque fait 290.5 GB et qu'il y a 143.77 GB de libre.
Je ne sais pas où voir l'espace que prend le host et m'étonne qu'il manquerait 100 MB car si le HDD était full, le système buggerait, serait ralenti ou pénible à l'utilisation, ce qui n'est pas le cas.

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 29 Fév 2020 19:18
par mackguil
Mr Coyote a écrit :Le DSM 6.2 a un espace de 16 GB en independent persistent
Debian 9 a 256 GB en thin provisioned et en prend 4
Pour le host je ne vois pas d'infos à partir que le disque fait 290.5 GB et qu'il y a 143.77 GB de libre.
Je ne sais pas où voir l'espace que prend le host et m'étonne qu'il manquerait 100 MB car si le HDD était full, le système buggerait, serait ralenti ou pénible à l'utilisation, ce qui n'est pas le cas.


Essaye en réduisant l'espace réservé à debian.

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 10 Mars 2020 11:54
par m3xiz
Il faut mettre le zip dans le datastore et pas dans tmp. Ensuite faire l’upgrade en pointant le datastore.

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 08 Jan 2021 18:36
par nicky_larson9
mr coyote
pourquoi mettre proxmox :D

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 10 Jan 2021 18:01
par Mr Coyote
@rodrigue
Cela n'a pas d'intérêt dans la configuration actuelle car il me faudrait repartir de zéro ou du moins prévoir que cela pourrait coincer (et donc faire un backup des 3 disques soit 30 To)
Donc éventuellement pour une nouvelle machine mais pas ici.

Il faudrait que je m'occupe à nouveau de cette mise à jour. Je me suis occupé d'autres choses entretemps, j'ai complètement zappé le truc.

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 10 Jan 2021 21:53
par item
Hello,

bizarre, moi j ai une ligne de commande a faire ! (en dehors du disable firewall)
https://tinkertry.com/easy-update-to-esxi-67

je ne telecharge rien !
je ne trouve plus le lien (url) .. y a juste une ligne de commande a copy-past.

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 10 Jan 2021 22:27
par mackguil
item a écrit :Hello,

bizarre, moi j ai une ligne de commande a faire ! (en dehors du disable firewall)
https://tinkertry.com/easy-update-to-esxi-67

je ne telecharge rien !
je ne trouve plus le lien (url) .. y a juste une ligne de commande a copy-past.


La ligne de commande de ton lien, télécharge un fichier d'update sur le web.

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 11 Jan 2021 00:07
par Mr Coyote
S'il n'y a qu'une ligne de commande (ou peu à faire), je suis intéressé. Pas urgent mais toujours bien à faire.

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 11 Jan 2021 14:18
par m3xiz
J'ai fait plusieurs update/upgrade sans problème. J'ai toujours utilisé la méthode offline. A savoir, je download depuis le site de VMWare l'update qu'il me faut. Je le transfer (scp) sur mon ESXI. je stoppe toutes mes vm, mets l'esxi en maintenance, upgrade, sortir de la maintenance et reboot.
Je n'ai eu des soucis que dernièrement en essayant de passer sous la version 7...ma carte réseau n'était plus supportée. Je pourrais peut-être passer en force mais je n'en ai pas vu l'intéretil ya peu d'intérêt pour l'instant.

Pour passer en maintenance:
vim-cmd hostsvc/maintenance_mode_enter

Pour update des VIb
esxcli software vib update -d /vmfs/volumes/datastore/patchbundle.zip

pour update des vers 7.0
esxcli software profile update -p VMware-ESXi-7.0.0-16324942-standard -d /vmfs/volumes/SSD1/VMware-ESXi-7.0.0-16324942-depot.zip

Pour sortir de la maintenance:
vim-cmd hostsvc/maintenance_mode_exit

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 11 Jan 2021 14:51
par nicky_larson9
Mr Coyote a écrit :@rodrigue
Cela n'a pas d'intérêt dans la configuration actuelle car il me faudrait repartir de zéro ou du moins prévoir que cela pourrait coincer (et donc faire un backup des 3 disques soit 30 To)
Donc éventuellement pour une nouvelle machine mais pas ici.

Il faudrait que je m'occupe à nouveau de cette mise à jour. Je me suis occupé d'autres choses entretemps, j'ai complètement zappé le truc.



30.000 k :D

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 11 Jan 2021 20:01
par item
Hello,
dans le precedent post, tu peux tester le -dry-run .. les commandes a faire sont la.

sinon j'ai retrouvé le lien :
https://esxi-patches.v-front.de/

quand tu click sur le lien exemple "ESXi-7.0U1c-17325551-standard " .. tu as une fenetre qui s'ouvre avec les commandes a faire

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 12 Jan 2021 00:36
par Mr Coyote
oui, Rodrigue, 3 disques de 8, 10 et 12 To en interne et deux disques de 8 et 10 To en USB.

Merci pour les liens et les lignes de commande, item. Je m'occupe de ça ce weekend.

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 12 Jan 2021 16:42
par nicky_larson9
Mr Coyote a écrit :oui, Rodrigue, 3 disques de 8, 10 et 12 To en interne et deux disques de 8 et 10 To en USB.


ah ok pour backup 3x 8,10,12 Tio :)

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 16 Jan 2021 17:09
par Mr Coyote
Les lignes de commande ne marchent pas ... :angry:

Code : Tout sélectionner
The ESXi Shell can be disabled by an administrative user. See the
vSphere Security documentation for more information.
[[email protected]:~] vim-cmd hostsvc/maintenance_mode_enter
[[email protected]:~] esxcli software profile update -p VMware-ESXi-6.5.0-20201103001-standard -d /vmfs/volumes/StockVm/VMware_esx-base_6.5.0-3.
149.17167537.vib
 [MetadataDownloadError]
 Could not download from depot at /vmfs/volumes/StockVm/VMware_esx-base_6.5.0-3.149.17167537.vib/index.xml, skipping (('/vmfs/volumes/StockVm/VMware_esx-base_6.5.0-3.149.17167537.vib/index.xml', '', 'file not found'))
        url = /vmfs/volumes/StockVm/VMware_esx-base_6.5.0-3.149.17167537.vib/index.xml
 Please refer to the log file for more details.
[[email protected]:~] esxcli software profile update -p VMware-ESXi-6.5.0-20201103001-standard -d /vmfs/volumes/StockVm/VMware_bootbank_esx-base
_6.5.0-3.149.17167537.vib
 [MetadataDownloadError]
 Could not download from depot at /vmfs/volumes/StockVm/VMware_bootbank_esx-base_6.5.0-3.149.17167537.vib/index.xml, skipping (('/vmfs/volumes/StockVm/VMware_bootbank_esx-base_6.5.0-3.149.17167537.vib/index.xml', '', 'file not found'))
        url = /vmfs/volumes/StockVm/VMware_bootbank_esx-base_6.5.0-3.149.17167537.vib/index.xml
 Please refer to the log file for more details.
[[email protected]:~] esxcli software profile update -p VMware-ESXi-6.5.0-202011002-standard -d /vmfs/volumes/StockVm/ESXi650-202011002.zip
 [NoMatchError]
 No image profile found with name 'VMware-ESXi-6.5.0-202011002-standard'
         id = VMware-ESXi-6.5.0-202011002-standard
 Please refer to the log file for more details.
[[email protected]:~] esxcli software profile update -p ESXi650-202011002 -d /vmfs/volumes/StockVm/ESXi650-202011002.zip
 [NoMatchError]
 No image profile found with name 'ESXi650-202011002'
         id = ESXi650-202011002
 Please refer to the log file for more details.
[[email protected]:~] esxcli software profile update /vmfs/volumes/StockVm/ESXi650-202011002.zip
Error: Unknown command or namespace software profile update /vmfs/volumes/StockVm/ESXi650-202011002.zip

[[email protected]:~] esxcli software vib update -d /vmfs/volumes/StockVm/ESXi650-202011002.zip
 [InstallationError]
 ('VMware_bootbank_esx-tboot_6.5.0-3.149.17167537', 'Could not find a trusted signer.')
       vibs = VMware_bootbank_esx-tboot_6.5.0-3.149.17167537
 Please refer to the log file for more details.
[[email protected]:~] esxcli software vib update -d /vmfs/volumes/StockVm/ESXi650-202011002.zip
 [InstallationError]
 ('VMware_bootbank_esx-base_6.5.0-3.149.17167537', 'Could not find a trusted signer.')
       vibs = VMware_bootbank_esx-base_6.5.0-3.149.17167537
 Please refer to the log file for more details.
[[email protected]:~] esxcli software profile update -p VMware-ESXi-6.5.0-20201103001-standard -d /vmfs/volumes/StockVm/ESXi650-202011002.zip
 [NoMatchError]
 No image profile found with name 'VMware-ESXi-6.5.0-20201103001-standard'
         id = VMware-ESXi-6.5.0-20201103001-standard
 Please refer to the log file for more details.
[[email protected]:~]

Une bonne âme ?

EDIT 18h08
Bon, c'est finalement passé avec la version de novembre 2018. Mais j'ai cette erreur
Code : Tout sélectionner
Cause: TypeError: _content is null
Version: 1.18.0
Build: 5270848
ESXi: 6.5.0
Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:84.0) Gecko/20100101 Firefox/84.0

Exception stack:

[email protected]://192.168.0.25/ui/scripts/main.js:379:17541
login/<@https://192.168.0.25/ui/scripts/main.js:385:30354
f/<@https://192.168.0.25/ui/scripts/main.js:320:10283
[email protected]://192.168.0.25/ui/scripts/main.js:320:17497
[email protected]://192.168.0.25/ui/scripts/main.js:320:16068
$evalAsync/<@https://192.168.0.25/ui/scripts/main.js:320:17584
[email protected]://192.168.0.25/ui/scripts/main.js:319:5691
nf/n.defer/c<@https://192.168.0.25/ui/scripts/main.js:319:7797


EDIT 18h26
MAJ OK vers la dernière version de ESXi 6.5.0
6.5.0 Update 3 (Build 17167537)

Pour la mise à jour 6.7, j'ai ceci
Code : Tout sélectionner
The ESXi Shell can be disabled by an administrative user. See the
vSphere Security documentation for more information.
[[email protected]:~] esxcli software vib install -d "/vmfs/volumes/StockVm/ESXi670-202011002.zip"
 [DependencyError]
 VIB HPE_bootbank_amsd_650.11.5.0-16.4240417 requires esx-version << 6.7.0, but the requirement cannot be satisfied within the ImageProfile.
 VIB HPE_bootbank_ilo_650.10.4.0.2-1OEM.650.0.0.4240417 requires esx-version << 6.7.0, but the requirement cannot be satisfied within the ImageProfile.
 VIB HPE_bootbank_fc-enablement_650.3.5.0.14-4240417 requires esx-version << 6.7.0, but the requirement cannot be satisfied within the ImageProfile.
 Please refer to the log file for more details.
[[email protected]:~] esxcli software vib install -d "/vmfs/volumes/StockVm/VMware_bootbank_esx-base_6.7.0-3.132.17167734.vib"
 [MetadataDownloadError]
 Could not download from depot at /vmfs/volumes/StockVm/VMware_bootbank_esx-base_6.7.0-3.132.17167734.vib/index.xml, skipping (('/vmfs/volumes/StockVm/VMware_bootbank_esx-base_6.7.0-3.132.17167734.vib/index.xml', '', 'file not found'))
        url = /vmfs/volumes/StockVm/VMware_bootbank_esx-base_6.7.0-3.132.17167734.vib/index.xml
 Please refer to the log file for more details.
[[email protected]:~] esxcli software vib install -d "/vmfs/volumes/StockVm/ESXi670-201806001.zip"
 [DependencyError]
 VIB HPE_bootbank_amsd_650.11.5.0-16.4240417 requires esx-version << 6.7.0, but the requirement cannot be satisfied within the ImageProfile.
 VIB HPE_bootbank_ilo_650.10.4.0.2-1OEM.650.0.0.4240417 requires esx-version << 6.7.0, but the requirement cannot be satisfied within the ImageProfile.
 VIB HPE_bootbank_fc-enablement_650.3.5.0.14-4240417 requires esx-version << 6.7.0, but the requirement cannot be satisfied within the ImageProfile.
 Please refer to the log file for more details.
[[email protected]:~]


EDIT 18h37
La VM Debian démarre.
La VM DSM6.2 ne démarre pas : Failed to power on virtual machine Wile_DSM6. Unable to enumerate all disks. Click here for more details.

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 17 Jan 2021 13:36
par Mr Coyote
Il y a un petit progrès car j'ai réussi à passer à la version 6.7 avec le zip du site HPE
Code : Tout sélectionner
[[email protected]:~] vmware -v
VMware ESXi 6.7.0 build-9484548

L'upgrade vers l'update 1 ne fonctionne pas
Code : Tout sélectionner
[[email protected]:~] esxcli software vib update -d /vmfs/volumes/StockVm/ESXi670U1HPE2019.zip
 [DependencyError]
 VIB VMware_bootbank_esx-base_6.7.0-1.39.11675023 requires esx-update << 6.7.0-1.40, but the requirement cannot be satisfied within the ImageProfile.
 VIB VMware_bootbank_esx-base_6.7.0-1.39.11675023 requires esx-update >= 6.7.0-1.39, but the requirement cannot be satisfied within the ImageProfile.
 Please refer to the log file for more details.

et la VM DSM6.2 ne démarre pas : Failed to power on virtual machine Wile_DSM6. Unable to enumerate all disks. Click here for more details.

Re: ESXI 6.5 - Mise à jour impossible vers 6.7

Message Publié : 17 Jan 2021 20:18
par vax
Question débile?
Il y a un intérêt à la 6.7?
J'ai un esxi 6.5.0U3 qui fonctionne super... sauf un driver que je dois downgrader à chaque upgrade pour avoir des perfs disques correctes. Il y a des nouveautés avec la 6.7?