recherche expert en excel

Pour tout ce qui est bavardage, hors-sujet et cie.

Modérateurs : Diamond, watch, Barbapapa, Casimir

recherche expert en excel

Message par freddo » 30 Nov 2019 15:50

Salut,
j'ai un soucis en excel, je dois trouver le montant total des vendeurs et le montant total des produits en utilisant la fonction SI avec des valeurs relatives et absolues.
Pouvez-vous m'aider ?
Image
Comme vous pouvez le voir dans la colonne E les trois premiers montants sont bons mais pas les autres et je n'arrive pas à trouver la solution.
Merci pour votre aide.
freddo
Habitué
Habitué
 
Message(s) : 893
Inscription : 08 Jan 2003 08:48
Localisation : Nimy

Re: recherche expert en excel

Message par David818 » 30 Nov 2019 17:41

Ton SI n'est pas bon...

Les 3 premiers sont bons car ils sont dans le même ordre que dans la colonne G.
G1 = C2
G2 = C3
G3 = C4
G4 = C5, faux, donc il applique la condition faux de ton si qui est bloquée sur H3 * D2, soit 39 * 12 = 468 !

La solution serait un SI imbriqué, (mais j'inverserais aussi l'ordre de tes conditions pour une meilleure lisibilité)

Si C2=G1 : vrai je fais le calcul, faux, je mets un nouveau SI
si C2=G2 : vrai je fais le calcul, faux, je mets un nouveau SI
Si C2=G3 : vrai, je fais le calcul, faux, je mets un message d'erreur vu que je n'ai que 3 produits.

Attention mettre les symboles $ correctement. Normalement uniquement sur $G$1, $G$2 et $G$3 et les H correspondant du calcul.
Gagnez 30 euros en ouvrant un compte Keytrade Bank : https://www.keytradebank.be/fr/promo/mgm/bienvenue/?HASH=76170B67A686271BA4D769F203496137. N'oubliez pas de mentionnez le code promo : MM6397869677 lors de l'inscription. Je bénéficierai également de 30 euros.

David
David818
Habitué
Habitué
 
Message(s) : 368
Inscription : 20 Avr 2016 08:22

Re: recherche expert en excel

Message par freddo » 30 Nov 2019 17:49

David818 a écrit :Ton SI n'est pas bon...

Les 3 premiers sont bons car ils sont dans le même ordre que dans la colonne G.
G1 = C2
G2 = C3
G3 = C4
G4 = C5, faux, donc il applique la condition faux de ton si qui est bloquée sur H3 * D2, soit 39 * 12 = 468 !

La solution serait un SI imbriqué, (mais j'inverserais aussi l'ordre de tes conditions pour une meilleure lisibilité)

Si C2=G1 : vrai je fais le calcul, faux, je mets un nouveau SI
si C2=G2 : vrai je fais le calcul, faux, je mets un nouveau SI
Si C2=G3 : vrai, je fais le calcul, faux, je mets un message d'erreur vu que je n'ai que 3 produits.

Attention mettre les symboles $ correctement. Normalement uniquement sur $G$1, $G$2 et $G$3 et les H correspondant du calcul.

Merci pour ta réponse, je vais essayer.
freddo
Habitué
Habitué
 
Message(s) : 893
Inscription : 08 Jan 2003 08:48
Localisation : Nimy

Re: recherche expert en excel

Message par freddo » 30 Nov 2019 18:28

malheureusement cela ne fonctionne pas.
freddo
Habitué
Habitué
 
Message(s) : 893
Inscription : 08 Jan 2003 08:48
Localisation : Nimy

Re: recherche expert en excel

Message par David818 » 30 Nov 2019 19:28

peux-tu étayer en mettant des images

1) la formule en E2
2) la formule en E3
Eventuellement, un printscreen avec les formules affichées au lieu du résultat ?
Gagnez 30 euros en ouvrant un compte Keytrade Bank : https://www.keytradebank.be/fr/promo/mgm/bienvenue/?HASH=76170B67A686271BA4D769F203496137. N'oubliez pas de mentionnez le code promo : MM6397869677 lors de l'inscription. Je bénéficierai également de 30 euros.

David
David818
Habitué
Habitué
 
Message(s) : 368
Inscription : 20 Avr 2016 08:22

Re: recherche expert en excel

Message par freddo » 30 Nov 2019 20:46

David818 a écrit :peux-tu étayer en mettant des images

1) la formule en E2
2) la formule en E3
Eventuellement, un printscreen avec les formules affichées au lieu du résultat ?

1) la formule en E2 =SI(C2=G1;D2*H1;SI(C2=$G$2;C2*$H$2;SI(C2=$G$3;D2*$H$3;"erreur")))
2) la formule en E3 =SI(C3=G2;D3*H2;SI(C3=$G$2;C3*$H$2;SI(C3=$G$3;D3*$H$3;"erreur")))
freddo
Habitué
Habitué
 
Message(s) : 893
Inscription : 08 Jan 2003 08:48
Localisation : Nimy

Re: recherche expert en excel

Message par David818 » 30 Nov 2019 20:58

freddo a écrit :
David818 a écrit :peux-tu étayer en mettant des images

1) la formule en E2
2) la formule en E3
Eventuellement, un printscreen avec les formules affichées au lieu du résultat ?

1) la formule en E2 =SI(C2=G1;D2*H1;SI(C2=$G$2;C2*$H$2;SI(C2=$G$3;D2*$H$3;"erreur")))
2) la formule en E3 =SI(C3=G2;D3*H2;SI(C3=$G$2;C3*$H$2;SI(C3=$G$3;D3*$H$3;"erreur")))


OK... j'ai une idée, mais tu n'as pas une image au moins pour le résultat, comme la première image que tu avais mis ?

Je ne sais pas dans quel cadre tu fais ces recherches, mais, si c'est dans le cadre d'une formation, je te conseille en tout cas de revoir le fonctionnement des symboles $ et leur utilité.

Je me permets de m'autociter

David818 a écrit :Attention mettre les symboles $ correctement. Normalement uniquement sur $G$1, $G$2 et $G$3 et les H correspondant du calcul.


Le cours d'Excel m'a traumatisé quand j'étais en secondaire (en 2003, je pense) et le cours d'informatique aussi, c'était le même prof. Pour l'Excel, il nous donnait cours sur du papier pour et on devait reproduire les formules pour faire ce qu'il demandait dans l'enoncé. Un peu difficile, personnellement, je travaille avec des "tests" si je n'ai pas le résultat escompté.
Gagnez 30 euros en ouvrant un compte Keytrade Bank : https://www.keytradebank.be/fr/promo/mgm/bienvenue/?HASH=76170B67A686271BA4D769F203496137. N'oubliez pas de mentionnez le code promo : MM6397869677 lors de l'inscription. Je bénéficierai également de 30 euros.

David
David818
Habitué
Habitué
 
Message(s) : 368
Inscription : 20 Avr 2016 08:22

Re: recherche expert en excel

Message par freddo » 30 Nov 2019 21:54

David818 a écrit :
freddo a écrit :
David818 a écrit :peux-tu étayer en mettant des images

1) la formule en E2
2) la formule en E3
Eventuellement, un printscreen avec les formules affichées au lieu du résultat ?

1) la formule en E2 =SI(C2=G1;D2*H1;SI(C2=$G$2;C2*$H$2;SI(C2=$G$3;D2*$H$3;"erreur")))
2) la formule en E3 =SI(C3=G2;D3*H2;SI(C3=$G$2;C3*$H$2;SI(C3=$G$3;D3*$H$3;"erreur")))


OK... j'ai une idée, mais tu n'as pas une image au moins pour le résultat, comme la première image que tu avais mis ?

Je ne sais pas dans quel cadre tu fais ces recherches, mais, si c'est dans le cadre d'une formation, je te conseille en tout cas de revoir le fonctionnement des symboles $ et leur utilité.

Je me permets de m'autociter

David818 a écrit :Attention mettre les symboles $ correctement. Normalement uniquement sur $G$1, $G$2 et $G$3 et les H correspondant du calcul.


Le cours d'Excel m'a traumatisé quand j'étais en secondaire (en 2003, je pense) et le cours d'informatique aussi, c'était le même prof. Pour l'Excel, il nous donnait cours sur du papier pour et on devait reproduire les formules pour faire ce qu'il demandait dans l'enoncé. Un peu difficile, personnellement, je travaille avec des "tests" si je n'ai pas le résultat escompté.

La prof que l'on a, on doit être autodictate
Comme je n'ai pas l'esprit logique, j'ai très difficile dans certains cours.
Image
freddo
Habitué
Habitué
 
Message(s) : 893
Inscription : 08 Jan 2003 08:48
Localisation : Nimy

Re: recherche expert en excel

Message par David818 » 01 Déc 2019 20:04

freddo a écrit :La prof que l'on a, on doit être autodictate
Comme je n'ai pas l'esprit logique, j'ai très difficile dans certains cours.
Image


Pour moi, le problème vient de tes symboles $ mal placés et/ou manquant.

A toi de chercher un peu et tester pour comprendre ton erreur et comment les placer, surtout que tu n'as pas recopié correctement ce que j'avais dit lors de ma première intervention.
Gagnez 30 euros en ouvrant un compte Keytrade Bank : https://www.keytradebank.be/fr/promo/mgm/bienvenue/?HASH=76170B67A686271BA4D769F203496137. N'oubliez pas de mentionnez le code promo : MM6397869677 lors de l'inscription. Je bénéficierai également de 30 euros.

David
David818
Habitué
Habitué
 
Message(s) : 368
Inscription : 20 Avr 2016 08:22

Re: recherche expert en excel

Message par freddo » 03 Déc 2019 07:31

David818 a écrit :
freddo a écrit :La prof que l'on a, on doit être autodictate
Comme je n'ai pas l'esprit logique, j'ai très difficile dans certains cours.
Image


Pour moi, le problème vient de tes symboles $ mal placés et/ou manquant.

A toi de chercher un peu et tester pour comprendre ton erreur et comment les placer, surtout que tu n'as pas recopié correctement ce que j'avais dit lors de ma première intervention.

Merci pour ton aide j'ai trouvé.
freddo
Habitué
Habitué
 
Message(s) : 893
Inscription : 08 Jan 2003 08:48
Localisation : Nimy

Re: recherche expert en excel

Message par David818 » 03 Déc 2019 19:23

freddo a écrit :Merci pour ton aide j'ai trouvé.


Peux-tu communiquer la solution qui t'a permis de trouver ? Au cas ou un autre chercherait et tomberait ici... ?
Gagnez 30 euros en ouvrant un compte Keytrade Bank : https://www.keytradebank.be/fr/promo/mgm/bienvenue/?HASH=76170B67A686271BA4D769F203496137. N'oubliez pas de mentionnez le code promo : MM6397869677 lors de l'inscription. Je bénéficierai également de 30 euros.

David
David818
Habitué
Habitué
 
Message(s) : 368
Inscription : 20 Avr 2016 08:22

Re: recherche expert en excel

Message par freddo » 03 Déc 2019 22:05

David818 a écrit :
freddo a écrit :Merci pour ton aide j'ai trouvé.


Peux-tu communiquer la solution qui t'a permis de trouver ? Au cas ou un autre chercherait et tomberait ici... ?

Voici la solution :
Image
freddo
Habitué
Habitué
 
Message(s) : 893
Inscription : 08 Jan 2003 08:48
Localisation : Nimy

Re: recherche expert en excel

Message par ptilib » 06 Déc 2019 23:34

C'est très bien ainsi effectivement, pas toujours facile de s'en sortir.

En conseil je sortirai la multiplication par DX du SI. C'est plus clair et plus simple si tu dois changer ça plus tard:
=SI(C2=G$1;H$1;SI(C2=G$2;H$2;SI(C2=G$3;H$3;0))) * D2

Et je sais que l'exercice portait sur le SI mais j'aurai plutôt fait ça via vlookup (rechercheV en français):
=RECHERCHEV(C2;G$1:H$3;2;FAUX)*D2

Et pour finir une astuce pour ajouter les $ dans les formules: utiliser la touche F4.
Ça les rajoute et en appuyant plusieurs fois ça passe par toutes les formes possibles. Plus rapide que de l'écrire à la main et peu de gens semblent le savoir / l'utiliser.

Bon courage.
ptilib
Habitué
Habitué
 
Message(s) : 324
Inscription : 15 Mars 2005 14:24
Localisation : St-Josse

Re: recherche expert en excel

Message par David818 » 07 Déc 2019 10:48

ptilib a écrit :C'est très bien ainsi effectivement, pas toujours facile de s'en sortir.

En conseil je sortirai la multiplication par DX du SI. C'est plus clair et plus simple si tu dois changer ça plus tard:
=SI(C2=G$1;H$1;SI(C2=G$2;H$2;SI(C2=G$3;H$3;0))) * D2

Intéressante idée. J'ai pris l'habitude de mettre les formules comme Freddo, mais cela peut semble plus lisible comme tu l'as fait. Je vais essayer d'y penser à l'occasion.

ptilib a écrit :Et je sais que l'exercice portait sur le SI mais j'aurai plutôt fait ça via vlookup (rechercheV en français):
=RECHERCHEV(C2;G$1:H$3;2;FAUX)*D2

C'est aussi plus lisible et cela permet d'éviter les si imbriqués à l'infini... et où cela devient, à un moment, illisible.

ptilib a écrit :Et pour finir une astuce pour ajouter les $ dans les formules: utiliser la touche F4.
Ça les rajoute et en appuyant plusieurs fois ça passe par toutes les formes possibles. Plus rapide que de l'écrire à la main et peu de gens semblent le savoir / l'utiliser.

Bon courage.

Très bon conseil. j'utilise toujours la touche F4 pour mettre les symboles $

Excel (et autre tableur) est un outil très performant, mais faut parfois un peu chercher et tester pour s'y retrouver.
Gagnez 30 euros en ouvrant un compte Keytrade Bank : https://www.keytradebank.be/fr/promo/mgm/bienvenue/?HASH=76170B67A686271BA4D769F203496137. N'oubliez pas de mentionnez le code promo : MM6397869677 lors de l'inscription. Je bénéficierai également de 30 euros.

David
David818
Habitué
Habitué
 
Message(s) : 368
Inscription : 20 Avr 2016 08:22

Re: recherche expert en excel

Message par freddo » 10 Déc 2019 07:25

ptilib a écrit :C'est très bien ainsi effectivement, pas toujours facile de s'en sortir.

En conseil je sortirai la multiplication par DX du SI. C'est plus clair et plus simple si tu dois changer ça plus tard:
=SI(C2=G$1;H$1;SI(C2=G$2;H$2;SI(C2=G$3;H$3;0))) * D2

Et je sais que l'exercice portait sur le SI mais j'aurai plutôt fait ça via vlookup (rechercheV en français):
=RECHERCHEV(C2;G$1:H$3;2;FAUX)*D2

Et pour finir une astuce pour ajouter les $ dans les formules: utiliser la touche F4.
Ça les rajoute et en appuyant plusieurs fois ça passe par toutes les formes possibles. Plus rapide que de l'écrire à la main et peu de gens semblent le savoir / l'utiliser.

Bon courage.

Merci pour ton explication, on n'a pas encore vu la fonction rechercheV
freddo
Habitué
Habitué
 
Message(s) : 893
Inscription : 08 Jan 2003 08:48
Localisation : Nimy

Re: recherche expert en excel

Message par cypl » 10 Déc 2019 09:05

SOMME.SI et RECHERCHE.V sont les 2 fonctions que j'aurais utilisé si l'intitulé de l'exercice l'autorisait
"Never attribute to malice that which is adequately explained by stupidity"
Avatar de l’utilisateur
cypl
Vieux Caillou
Vieux Caillou
 
Message(s) : 6335
Inscription : 20 Sep 2008 11:38
Localisation : N 50.886 E 4.360


Retour vers Bavardage

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Google Adsense [Bot], nabu